Skip to main content

Cornell University

Longview Setup and Technical Requirements

This article applies to: Longview

In This Article

This page is intended for IT support professionals. End users should contact local IT support.

Longview Software Requirements

  • Windows 10 or 11 (64-bit)
  • MS Office 365
  • Microsoft Edge version 92.0 or higher
Tablets, smart phones, and Apple computers are not supported. 

Use Longview with Microsoft Edge

Microsoft Edge, version 92.0 and higher, does not require any configuration changes to work with Longview. For more detailed information, see Longview Budget and Capital Planning in Microsoft Edge.

Configure Internet Explorer version 11 for Longview

To configure Internet Explorer version 11 for use with Longview:

  1. Launch Internet Explorer (version 11). Click Tools (gear icon at upper right), then Internet Options.
  2. Click the Security tab, then under Select a zone to view or change security settings, click Trusted sites.
  3. Click Sites.
  4. In the Add this website to the zone field, type https://cornell.lvcloud.com.
  5. Click Close.
  6. While still on the Security tab, uncheck the Enable Protected Mode box if it is checked.
  7. Make sure the slider for Security level for this zone is set to Medium.
  8. Click OK.

Launch Longview

To launch Longview:

  1. Open Internet Explorer (version 11, 32-bit).
  2. In the Address bar, type https://cornell.lvcloud.com/CornellPrd.
  3. Sign in using your Cornell NetID credentials.

Comments?

To share feedback about this page or request support, log in with your NetID

At Cornell we value your privacy. To view
our university's privacy practices, including
information use and third parties, visit University Privacy.