Skip to main content

Longview Technical Requirements

This article applies to: Longview


This page is intended for IT support professionals. End users should contact local IT support.

Requirements for Longview 2017 are consistent with CIT's Endpoint Management service. Computers must conform with the following:

  • Windows 7 or 10 (32-bit or 64-bit)
  • MS Office 2013 or 2016 (32-bit)
  • MS Excel 2013 or 2016 (32 bit)
  • Internet Explorer (IE) version 11 (32 bit)
  • JRE 1.8.0
  • .NET version 4.5.2 or 4.6.1

Systems that do not meet these requirements will experience installation failures, application errors, and application dysfunction.

Tablets, smart phones, and Apple computers are not supported. 

An installation package has been built and tested by the Desktop Engineering group in CIT Support. It includes:

  • Longview for Excel Add-in MSI
  • Longview Web Controls MSI
  • Group policy for installing certificates
  • Group policy for setting Internet Explorer settings

About this Article

Last updated: 

Monday, August 13, 2018 - 4:38pm

Audience: 

Staff

Was this page helpful?

Your feedback helps improve the site.

Comments?