Skip to main content

Bomgar Technical Requirements

This article applies to: Bomgar


Bomgar works with

  • Windows 7 or newer
  • Mac OS X 10.8 - 10.11 and macOS 10.12 or newer
  • iOS 8 or newer (screen sharing requires tethering)
  • Many versions of Linux (Ubuntu, Red Hat, Fedora, and Suse)

Was this page helpful?

Your feedback helps improve the site.

Comments?