Skip to main content

Safari and Edge Support for Security Keys in Two-Step Login

Related services: Two-Step Login


Cornell Two-Step Login now supports security keys when using Apple Safari for macOS (version 13 or higher) or Microsoft Edge (version 79 or higher). Previously, these USB devices for completing the second step of a login only worked with the Chrome and Firefox browsers.

More information about using security keys.

Was this page helpful?

Your feedback helps improve the site.

Comments?