Skip to main content

Mobile Updates Impact Outlook for iOS

Related services: Email for Faculty and Staff

To use Microsoft Office Mobile applications like Outlook Mail and Calendar on your iPhone or iPad, your iOS device now requires iOS 10.0 or later. While older versions of Outlook will still work on devices running iOS 9, these devices will not get new app updates and users can expect a degraded experience of the Outlook for iOS app over time.

Was this page helpful?

Your feedback helps improve the site.