Skip to main content

Longview Setup and Technical Requirements

This article applies to: Longview


This page is intended for IT support professionals. End users should contact local IT support.

Longview Software Requirements

  • Windows 7 or 10 (32-bit or 64-bit)
  • MS Office 2016 or 2019 (32-bit or 64-bit)
  • Internet Explorer (IE) version 11 (32 bit)
Tablets, smart phones, and Apple computers are not supported. 

Configure Internet Explorer version 11 for Longview

To configure Internet Explorer version 11 for use with Longview:

  1. Launch Internet Explorer (version 11). Click Tools (gear icon at upper right), then Internet Options.
  2. Click the Security tab, then under Select a zone to view or change security settings, click Trusted sites.
  3. Click Sites.
  4. In the Add this website to the zone field, type https://cornell.lvcloud.com.
  5. Click Close.
  6. While still on the Security tab, uncheck the Enable Protected Mode box if it is checked.
  7. Make sure the slider for Security level for this zone is set to Medium.
  8. Click OK.

Launch Longview

To launch Longview:

  1. Open Internet Explorer (version 11, 32-bit).
  2. In the Address bar, type https://cornell.lvcloud.com/CornellPrd.
  3. Sign in using your Cornell NetID credentials.

About this Article

Last updated: 

Wednesday, October 21, 2020 - 1:37pm

Audience: 

Staff

Was this page helpful?

Your feedback helps improve the site.

Comments?